Exciting News! Major Release of DDF – Version [2.1]
Scheduled for February 12, 2026 at 2:00 PM – 3:00 PM
Affects
myPlant AI
Under maintenance from 2:00 PM to 12:00 AM
Data Driven Forecasting
Under maintenance from 2:00 PM to 12:00 AM
In progress
February 12, 2026 at 2:00 PMIn progress
February 12, 2026 at 2:00 PMMaintenance is now in progress
Update
February 12, 2026 at 1:00 PMUpdate
February 12, 2026 at 1:00 PMDear User,
We’re thrilled to announce the launch of DDF Version 2.21, featuring:
Rebranding
More validations in differnent steps of the process
Holiday management feature
Overview of approval in your region
Improvements in the handling in step 4
many more different improvements
to enhance, and elevate your experience!
This upgrade will occur transparently with zero impact on user experience.
Thank you for your trust!
INNIO Digital Team
Update
February 12, 2026 at 1:00 PMUpdate
February 12, 2026 at 1:00 PMMaintenance has completed successfully
Planned
February 05, 2026 at 1:00 AMPlanned
February 05, 2026 at 1:00 AMDear User,
We’re thrilled to announce the launch of DDF Version 2.21, featuring:
Rebranding
More validations in differnent steps of the process
Holiday management feature
Overview of approval in your region
Improvements in the handling in step 4
many more different improvements
to enhance, and elevate your experience!
This upgrade will occur transparently with zero impact on user experience.
Thank you for your trust!
INNIO Digital Team